.hack//G.U. Last Recode PC System Requirements

Game: .hack//G.U. Last Recode
Release Date: 2017-11-02
Website:
Publishers: Bandai Namco Entertainment, BANDAI NAMCO Entertainment US
Developers: BANDAI NAMCO Entertainment America, CyberConnect2 Co.
Genres: RPG
Platforms: playstation4, pc


.hack//G.U. Last Recode System Requirements. See what PC specifications are needed for running .hack//G.U. Last Recode game smoothly. Can I Run .hack//G.U. Last Recode?. This information will help you in making a gaming PC setup for playing .hack//G.U. Last Recode .hack//G.U. Last Recode PC requirements and .hack//G.U. Last Recode hardware requirements

Minimum System requirements


  • Requires a 64-bit processor and operating system
  • OS: Windows 7/8/10 (64-bit OS required)
  • Processor: AMD Phenom II X4 940, 3.0 GHz / Intel Core i3-2100, 3.10 GHz
  • Memory: 4 GB RAM
  • Graphics: Radeon HD 6870, 1 GB / GeForce GTX 460, 768 MB
  • DirectX: Version 11
  • Storage: 40 GB available space
  • Sound Card: DirectX compatible soundcard or onboard chipset

Recommended System requirements


  • Requires a 64-bit processor and operating system
  • OS: Windows 7/8/10 (64-bit OS required)
  • Processor: AMD A10-7850K, 3.7 GHz / Intel Core i3-2125, 3.30 GHz
  • Memory: 4 GB RAM
  • Graphics: GeForce GTX 660 TI 3GB or higher
  • DirectX: Version 11
  • Storage: 40 GB available space
  • Sound Card: DirectX compatible soundcard or onboard chipset

Frequenty Asked Questons

Can my system run .hack//G.U. Last Recode?

Check the minimum system requrements. If your PC has better specs than minimum system requirements, .hack//G.U. Last Recode should run fine on your system.

Can I run .hack//G.U. Last Recode?

If you system meets minimum system requirements of the game, .hack//G.U. Last Recode should run fine on your system. The better system specs, the smoother gameplay.